Joomla! e PHP7 - 4 ragioni per aggiornare



Con l'arrivo di Joomla! 4, è bene incominciare a sensibilizzare tutti nell'utilizzo di PHP7 e quindi questo sarà solo il primo di molti articoli a riguardo.

Joomla! 4, infatti,  richiederà by default PHP 7. Molti hosting offrono già PHP 7 nei loro pacchetti e dovrebbe essere abbastanza facile cambiare la versione di PHP.


Suggerimento: prima di cambiare la versione di PHP, assicuratevi di verificare che anche tutti i plugin installati supportino la nuova versione, in caso contrario aggiornateli.

Host.it ad esempio supporta già da diverso tempo PHP 7 che è attivo di default su tutti i piani di hosting per Joomla!.

Abbiamo identificato 4 buoni motivi per cui dovresti aggiornare la versione di PHP sulla tua installazione Joomla!

PHP 7 è più veloce

PHP 7 ha un motore di esecuzione più performante che migliora sensibilmente le prestazioni di un sito web fino a due volte rispetto PHP 5, consuma il 50% in meno della memoria ed è più sicuro contro attacchi hacker.

Joomla! 4 sarà fantastico

Joomla! 4 conterrà molti miglioramenti sia per gli utenti utilizzatori che per gli sviluppatori. Un codice ripulito, una struttura rinnovata, grandi novità e molto altro ancora. Bootstrap 4 sarà implementato by design nel core, ci saranno 2 nuovi template (frontend e backend), il nuovo media manager sarà un fiore all'occhiello.

Uno dei prossimi articoli che andremo a pubblicare sarà proprio dedicato a Joomla! 4, faremo un'intervista in esclusiva a chi sta letteralmente mettendo le mani nel codice, per farci svelare qualche "anteprima".

È più sicuro e supportato

Le versioni precedenti a PHP 5.6 non sono più supportate e quindi non vengono più rilasciati bug fix. Se dovesse uscire un'importante vulnerabilità in queste versioni obsolete, nessuno le risolverà e il vostro sito sarà facilmente attaccabile. E' quindi consigliato utilizzare sempre l'ultima versione stabile di PHP, supportata da Joomla! e ovviamente dai tutti i plugin installati.

Ma, ma ... Cosa succede se non riuscite ad aggiornare?

Joomla! 3.9 sarà supportato per due anni dopo il suo rilascio. Ciò significa che potrete continuare a gestire le vostre installazioni di Joomla! 3 2020 circa, ma ovviamente, vi perderete tutte le nuove feauture della 4.

Diciamocela tutta, se il vostro hosting non supporta PHP 7, è arrivato il momento di cambiare hosting.

Siamo tutti noi in trepidante attesa di iniziare a fare i beta test sulla versione 4.0 e di vederla presto stabile ed in produzione.

Questo articolo è stato liberamente tratto dalle news di joomla.org

CommentaCommenta sul forum